No sound at all except for Shift key

Post Reply
blubub94
Posts: 1
Joined: Wed Feb 10, 2021 7:11 am
My devices: Macbook pro - macOS Big Sur
Flag: Indonesia

No sound at all except for Shift key

Post by blubub94 »

Hi,

I downloaded the app and purchased the sound pack, however the sounds only come up from the shift button but not other keys at all. Is there a way to fix this?

Thank you in advance!

User avatar
Mr. Kibernetik
Site Admin
Posts: 4613
Joined: Mon Nov 19, 2012 10:16 pm
My devices: iPad, iPhone, MacBook
Location: Russia
Flag: Russia

Re: No sound at all except for Shift key

Post by Mr. Kibernetik »

One user wrote a review in App Store. He reported exactly the same problem and blamed the application.
Some time after he updated his review and said that he 'googled' something and fixed that problem on his side. The bad thing is that he did not write what he had done.

I know that if there is some security restriction then application doesn't get any keys touches except shift, fn, control, option and command buttons. This generally happens in security-protected text fields like password input fields. In all other cases macOS freely allows applications to intercept keys touches.
I can suppose that your system configuration or some other software blocks keys touches system-wide messaging and prevents Loud Typer from receiving keys touches events.

Please let me know if you find the solution. I hope you can find it.

User avatar
Mr. Kibernetik
Site Admin
Posts: 4613
Joined: Mon Nov 19, 2012 10:16 pm
My devices: iPad, iPhone, MacBook
Location: Russia
Flag: Russia

Re: No sound at all except for Shift key

Post by Mr. Kibernetik »

Ok, I got the same situation myself.
There were only sound effects from shift, fn, option and command keys, but not from any letter keys.

And I found out that this was a Safari/macOS bug. It entered the security mode when I was typing a password at some web page in Safari (in this mode macOS does not allow any application to receive any key presses except control buttons like shift, etc while it is in the security protected field), but it did not exit this mode even after that web page with the password field was closed.

So, restarting the Safari app resolved the problem.

Post Reply